CocoaPods找不到Pod&Quot;Firebase/Core |CLOUD_FIRESTORE,FLUTTER的兼容版本

本教程将介绍CocoaPods找不到Pod&Quot;Firebase/Core“|CLOUD_FIRESTORE,FLUTTER的兼容版本的处理方法,这篇教程是从别的地方看到的,然后加了一些国外程序员的疑问与解答,希望能对你有所帮助,好了,下面开始学习吧。

CocoaPods找不到Pod&Quot;Firebase/Core |CLOUD_FIRESTORE,FLUTTER的兼容版本 教程 第1张

问题描述

我在Pod中遇到一些问题,请参见下面

在调试模式下启动iPhone X上的lib/main.dart.
正在运行Pod安装.
CocoaPods的输出:

正在准备

Analyzing dependencies

Inspecting targets to integrate
  Using `ARCHS` setting to build architectures of target `Pods-Runner`: (``)

Fetching external sources
-> Fetching podspec for `Flutter` from `.symlinks/flutter/ios`
-> Fetching podspec for `cloud_firestore` from `.symlinks/plugins/cloud_firestore/ios`
-> Fetching podspec for `firebase_core` from `.symlinks/plugins/firebase_core/ios`
-> Fetching podspec for `shared_preferences` from `.symlinks/plugins/shared_preferences/ios`
-> Fetching podspec for `url_launcher` from `.symlinks/plugins/url_launcher/ios`

Resolving dependencies of `Podfile`
[!] CocoaPods could not find compatible versions for pod "Firebase/Core":
  In Podfile:
 cloud_firestore (from `.symlinks/plugins/cloud_firestore/ios`) was resolved to 0.0.1, which depends on
Firebase/Core

Specs satisfying the `Firebase/Core` dependency were found, but they required a higher minimum deployment target.
CocoaPods could not find compatible versions for pod "GoogleUtilities/MethodSwizzler":
  In Podfile:
 cloud_firestore (from `.symlinks/plugins/cloud_firestore/ios`) was resolved to 0.0.1, which depends on
Firebase/Core was resolved to 5.8.0, which depends on
  FirebaseAnalytics (= 5.1.2) was resolved to 5.1.2, which depends on
 GoogleUtilities/MethodSwizzler (~> 5.2.0)

Specs satisfying the `GoogleUtilities/MethodSwizzler (~> 5.2.0)` dependency were found, but they required a higher minimum deployment target.
CocoaPods could not find compatible versions for pod "gRPC-Core":
  In Podfile:
 cloud_firestore (from `.symlinks/plugins/cloud_firestore/ios`) was resolved to 0.0.1, which depends on
Firebase/Firestore was resolved to 5.8.0, which depends on
  FirebaseFirestore (= 0.13.3) was resolved to 0.13.3, which depends on
 gRPC-C++ (~> 0.0.3) was resolved to 0.0.3, which depends on
gRPC-C++/Implementation (= 0.0.3) was resolved to 0.0.3, which depends on
  gRPC-Core (= 1.14.0)

 cloud_firestore (from `.symlinks/plugins/cloud_firestore/ios`) was resolved to 0.0.1, which depends on
Firebase/Firestore was resolved to 5.8.0, which depends on
  FirebaseFirestore (= 0.13.3) was resolved to 0.13.3, which depends on
 gRPC-ProtoRPC (~> 1.0) was resolved to 1.14.1, which depends on
gRPC-ProtoRPC/Main (= 1.14.1) was resolved to 1.14.1, which depends on
  gRPC (= 1.14.1) was resolved to 1.14.1, which depends on
 gRPC/Main (= 1.14.1) was resolved to 1.14.1, which depends on
gRPC-Core (= 1.14.1)

/Library/Ruby/Gems/2.3.0/gems/molinillo-0.6.5/lib/molinillo/resolution.rb:328:in `raise_error_unless_state'
/Library/Ruby/Gems/2.3.0/gems/molinillo-0.6.5/lib/molinillo/resolution.rb:310:in `block in unwind_for_conflict'
/Library/Ruby/Gems/2.3.0/gems/molinillo-0.6.5/lib/molinillo/resolution.rb:308:in `tap'
/Library/Ruby/Gems/2.3.0/gems/molinillo-0.6.5/lib/molinillo/resolution.rb:308:in `unwind_for_conflict'
/Library/Ruby/Gems/2.3.0/gems/molinillo-0.6.5/lib/molinillo/resolution.rb:684:in `attempt_to_activate'
/Library/Ruby/Gems/2.3.0/gems/molinillo-0.6.5/lib/molinillo/resolution.rb:254:in `process_topmost_state'
/Library/Ruby/Gems/2.3.0/gems/molinillo-0.6.5/lib/molinillo/resolution.rb:182:in `resolve'
/Library/Ruby/Gems/2.3.0/gems/molinillo-0.6.5/lib/molinillo/resolver.rb:43:in `resolve'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/resolver.rb:123:in `resolve'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/installer/analyzer.rb:781:in `block in resolve_dependencies'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/user_interface.rb:64:in `section'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/installer/analyzer.rb:779:in `resolve_dependencies'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/installer/analyzer.rb:88:in `analyze'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/installer.rb:243:in `analyze'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/installer.rb:154:in `block in resolve_dependencies'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/user_interface.rb:64:in `section'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/installer.rb:153:in `resolve_dependencies'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/installer.rb:116:in `install!'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/command/install.rb:41:in `run'
/Library/Ruby/Gems/2.3.0/gems/claide-1.0.2/lib/claide/command.rb:334:in `run'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods/command.rb:52:in `run'
/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.5.3/bin/pod:55:in `<top (required)>'
/usr/local/bin/pod:22:in `load'
/usr/local/bin/pod:22:in `<main>'

CocoaPods的错误输出:

[33mWARNING:CocoaPods要求您的终端使用UTF-8编码。
考虑将以下内容添加到~/.profile:

 export LANG=en_US.UTF-8
 [0m

[!] Automatically assigning platform `ios` with version `8.0` on target `Runner` because no platform was specified. Please specify a platform for this target in your Podfile. See `https://guides.cocoapods.org/syntax/podfile.html#platform`.

运行Pod安装时出错
在iPhone X上启动应用程序时出错。

推荐答案

我的设置:VS代码,颤动

如果您没有Podfile.lock文件并且pod update没有帮助,请尝试此操作:

    转到项目中的ios/Pods/Local Podspecs目录

    检查每个json文件,查找所需的最高IOS版本。我的在其中一些"ios": "10.0"

    返回ios/目录

    打开Podfile文件

    取消注释# platform :ios, '9.0',并将9.0替换为2.步骤中版本,例如10.0

      # platform :ios, '9.0'&gt;platform :ios, '10.0'

    运行pod install,错误应该消失

好了关于CocoaPods找不到Pod&Quot;Firebase/Core“|CLOUD_FIRESTORE,FLUTTER的兼容版本的教程就到这里就结束了,希望趣模板源码网找到的这篇技术文章能帮助到大家,更多技术教程可以在站内搜索。