REQUIRED('node-Fetch')提供ERR_REQUIRED_ESM

本教程将介绍REQUIRED('node-Fetch')提供ERR_REQUIRED_ESM的处理方法,这篇教程是从别的地方看到的,然后加了一些国外程序员的疑问与解答,希望能对你有所帮助,好了,下面开始学习吧。

REQUIRED('node-Fetch')提供ERR_REQUIRED_ESM 教程 第1张

问题描述

我只使用

const fetch = require('node-fetch')

我得到

Error [ERR_REQUIRE_ESM]: require() of ES Module C:UsersAlexDesktopollbot
ode_modules
ode-fetchsrcindex.js from C:UsersAlexDesktopollbotindex.js not supported.
Instead change the require of C:UsersAlexDesktopollbot
ode_modules
ode-fetchsrcindex.js in C:UsersAlexDesktopollbotindex.js to a 
dynamic import() which is available in all CommonJS modules.
{
  code: 'ERR_REQUIRE_ESM'
}

我的所有其他包都可以工作,只有节点获取可以做到这一点。要使用节点获取,我应该做些什么?

推荐答案

来自node-fetchpackage readme:

节点获取是仅限ESM的模块-您不能使用导入它
需要。我们建议您继续使用v2,它是用CommonJS构建的
除非你自己使用ESM。我们将继续发布严重错误
已对其进行修复。

如果要require,请降级到v2。

另一个选项是使用异步import('node-fetch').then(...)

好了关于REQUIRED('node-Fetch')提供ERR_REQUIRED_ESM的教程就到这里就结束了,希望趣模板源码网找到的这篇技术文章能帮助到大家,更多技术教程可以在站内搜索。